Kevser 4 months ago
DevOps

Error Fix 


Osx virtualenv python error after software update

Error message:
➜ xxxxxx git:(master) ✗ virtualenv env
zsh: no such file or directory: /Library/Frameworks/Python.framework/Versions/3.9/bin/virtualenv

➜  xxxxx git:(master) ✗ pip install virtualenv
Requirement already satisfied: virtualenv in /usr/local/lib/python3.9/site-packages (20.2.2)
Requirement already satisfied: appdirs<2,>=1.4.3 in /usr/local/lib/python3.9/site-packages (from virtualenv) (1.4.4)
Requirement already satisfied: six<2,>=1.9.0 in /usr/local/lib/python3.9/site-packages (from virtualenv) (1.15.0)
Requirement already satisfied: filelock<4,>=3.0.0 in /usr/local/lib/python3.9/site-packages (from virtualenv) (3.0.12)
Requirement already satisfied: distlib<1,>=0.3.1 in /usr/local/lib/python3.9/site-packages (from virtualenv) (0.3.1)

Solution:

python3 -m venv venv
source ./venv/bin/activate
or use pyenv and delete brew python versions because error is caused by brew